Our CDN provider is down
Incident Report for Binary.com
Resolved
We've enabled back our CDN. Issue resolved
Posted almost 3 years ago. Oct 26, 2015 - 09:38 UTC
Identified
We're having site issues with our CDN provider, we've temporarily disabled our CDN and will take sometime for the site to recover
Posted almost 3 years ago. Oct 26, 2015 - 07:28 UTC