Overzealous CloudFlare challenging
Incident Report for Binary.com
Resolved
We believe we have mitigated this issue with our upstream provider. Thank you for your patience.
Posted over 4 years ago. Jan 20, 2014 - 14:43 UTC
Investigating
A number of customers have reported that they are being challenged by CloudFlare when trying to access the site. We are working with CloudFlare to resolve this issue.
Posted over 4 years ago. Jan 20, 2014 - 10:39 UTC